En Popüler WordPress Eklentilerinden Birinde Güvenlik Açıkları Keşfedildi

En Popüler WordPress Eklentilerinden Birinde Güvenlik Açıkları Keşfedildi

Günümüzde internet sitesi geliştirmek isteyen bir kişinin ilk seçeneklerinden birisi WordPress platformudur. İster tecrübeli ister tecrübesiz herkes tarafından kullanılabilen WordPress, kolaylığı ve sahip olduğu her kullanıcıya hitap edecek kadar geniş eklenti kütüphanesiyle internet dünyasındaki popülerliğini korumaya devam ediyor.

Ancak bugün, WordPress’in en popüler eklentilerinden birisi hakkında önemli bir uyarı yapıldı. 2007 yılında yayınlanan ve 800 binden fazla aktif WordPress sitesinde kullanılan galeri eklentisi NextGEN Gallery’de birden fazla güvenlik açığı keşfedildi. Uygulama geliştiricileri, keşfedilen güvenlik açıklarını kapatmayı başardı ve tüm kullanıcılarının eklentiyi güncellemeleri gerektiğini söyledi.

Site direkt ele geçirilebiliyor:

wordpress

Wordfence Threat Intelligence tarafından keşfedilen güvenlik açıkları, iki adet “cross-site request forgery (CSRF/XSRF)” isimli güvenlik açığıydı. Güvenlik açıkları, araştırmacılar tarafından sırasıyla “yüksek şiddet” ve “kritik” olarak sınıflandırıldı. Açıklar, bir internet sitesinin ele geçirilmesine neden olabilme potansiyeline sahipti.

Eklentideki güvenlik açıklarından yararlanmak isteyen bir saldırgan, öncelikle WordPress yöneticisini bir şekilde kandırmalıydı. Kötü niyetli bağlantılar ya da yemleme yoluyla tamamlanabilecek bu aşamanın ardından saldırgan, internet sitesine kötü niyetli bağlantılar ve yemleme mekanizmaları ekleyebilirlerdi. Ayrıca sitenin kontrolü de tamamen onlara geçiyordu.

Wordfence, paylaştığı blog yazısında bu saldırının belli bir derecede sosyal mühendislik gerektirdiğini ifade etti. NextGEN Gallery eklentisinin geliştiricileri güvenlik açıklarını kapatan bir güncelleme yayınlamış olsalar da bu güncelleme henüz hedefine ulaşmadı. Geliştiriciler, şu ana kadar 300 bin kullanıcının gerekli güncellemeyi yüklediğini, geri kalan 500 binden fazla kullanıcınınsa internet sitelerinin güvensiz olduğunu açıkladı.

Author: ahmet

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir